.:: TechBlog ::. RSS Feed

17.09.2004WindowsXP SP2 arp1394.sys Bluescreen
WindowsXP SP2 steht für mehr Sicherheit und Komfort. Nie war ein (Windows) System so stabil. Naja, beinahe zumindest...
Nach anfänglichem Zögern, beschloss ich also auch den Schritt zum SP2 zu wagen. Nach einer Stunde und ein wenig Upgraden der AV und PF Programme, schien auch noch alles zu funktionieren. Super! Damit können wir das Notebook ja wieder in den Ruhezustand versetzen. Doch sollte sich das schwieriger gestalten als zunächst angenommen. Mich erwartete ein Bluescreen mit dem Verweis auf meinen Firewire Anschluss. Fehler in der arp1394.sys!
Ein Treiberupdate war nicht verfügbar und jeder Versuch den Treiber zu deaktivieren oder zu deinstallieren sollte einen weiteren Bluescreen verursachen. Die einzige Lösung gestaltet sich wie folgt:

Die arp1394.sys aus der C:\Windows\Driver Cache\i386\sp1.cab extrahieren und im abgesicherten Modus (!) mit der bestehenden C:\Windows\system32\drivers\arp1394.sys überschreiben. Im Anschluss funktionierte alles wieder wie es sollte.

Update:

Wie sich nun herausstellte lag der Fehler an der Personal Firewall Kerio 4.1. Ein nun zur Verfügung gestelltes Update beseitigt den besprochenen Bluescreen und ist über die Homepage oder direkt über das Programm abrufbar. thx Niko

Kommentare:

Kommentiert von missl.de am: 30.09.2004 um 02:49:00
Ich schätze das PROBLEM IST UNABHÄNGIG VON GERÄT UND SPs, EINE BESTIMMTE VERSION VON KERIO FIREWALL IST DER VERURSACHER

Hätte niemals gedacht das es die Firewall ist! Mal schauen, ob danach das Grauen ein Ende hat.
Hab schon gedacht ich muss das Scheiß-Notebook nach Europa schicken ;) Bin grad Austauschschüler in den USA...

Okay, dann lassen wir mal das extrem langsame Ammi-AOL-modem-internet laden...


Dankeschön und Grüße aus San Antonio, TX in die Heimat!
Kommentiert von Niko am: 29.09.2004 um 11:34:49
Hallo Leute, das Problem ist die Kerio Personal Firewall in Verbindung mit dem SP2!! Wer Kerio installiert hat, sollte auf die 4.1.1 updaten, da wurde folgendes gefixed:

4.1.1 - September 29, 2004
- fixed problems with firewire adapters when they were disabled or computer was hibernated

tja, das war wohl genau das Problem. Nachdem ich die neue Version installiert habe, funktioniert wieder alles, auch mit dem SP2-Firewire-Treiber ;)
Kommentiert von Ralph am: 28.09.2004 um 17:47:50
Ich hatte das Problem obwohl ich gar kein sp2 installiert hatte. Dafür hatte ich meine Kerio Firewall von 4.0.16 auf 4.1 aktualisiert (diese Version soll sp2-kompatibel sein). Danach kamen die besagten Bluescreens wenn der Rechner in den Standby gehen sollte. Die Version von arp1394.sys aus der C:\Windows\Driver Cache\i386\sp1.cab war übrigens identisch mit der aktiven Version. Also habe ich einfach wieder die alte Version der Firewall installiert und alles funktioniert wieder.
Gruß
Ralph
Kommentiert von Nino (ucaraccu AT wtnet.de) am: 28.09.2004 um 15:55:46
Hi... also ich habe auch immer einen Bluescreen wenn ich versuche die Firewire Karte zu deaktivieren oder das Notebook in den Ruhezustand geht. Schuld soll die arp1394.sys sein! Jetzt das doofe. Ich habe die arb1394.sys wie vorgeschlagen schon durch DIVERSE andere Versionen ersetzt! Nichts! Es hilft alles nichts. Nun noch eine Interessante beobachtung.
Kommentiert von Niko am: 28.09.2004 um 15:02:22
Hat bei mir das Problem ebenfalls gelöst (Acer Travelmate 8006). Verwende jetzt wieder den arp1394.sys in der SP1-Version.
Kommentiert von Marco am: 26.09.2004 um 14:23:18
Mir hat der Tip geholfen. XP pro auf Acer TM 290. Danke!
Kommentiert von Stefan (tausch.it AT drummit.de) am: 26.09.2004 um 11:05:06
Hm hab das gleiche Problem, wenn die Firewire-Karte aktiviert ist, bekomme ich beim Systemstart Bluescreens mit einer Fehlermeldung in der auf die arp1394.sys hingewiesen wird.
Wenn ich nach deinem Prinzip vorgehe bekomme ich den Fehler allerdings immernoch!
Egal mit welcher Treiberversion (der Version von WindowsXP ohne Servicepacks, der vom SP1 und der vom SP2) bekomme ich Bluescreens.
Allerdings erst nach der Systemneuinstallation. Vorher war alles in Ordnung.

Ich gehe mal davon aus, dass du nicht noch einen 2. Lösungsansatz hast, oder?

MfG Stefan

Kommentar hinzufügen:

E-Mail Adresse:    Name:   

Kommentar*:

Um unerwünschten, automatisierten Einträgen vorzubeugen muss abschließend ein Code eingegeben werden. Diese finden sie direkt unter diesem Text auf der linken Seite.

Code eingeben*:     Security Code

* Pflichtfelder

Impressum